Hi 你好,欢迎访问!登录
当前位置:首页 - 网络模拟器 - 正文 君子好学,自强不息!

GNS3做RIP,EIGRP.OSPF路由重分布

2011-01-14网络模拟器撒加9376°c
A+ A-

点击查看原图

Router 1 configure:

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 12.12.12.2 255.255.255.0
!
interface Loopback2
 ip address 21.2.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0

router rip
 version 2
 redistribute connected metric 2
 network 10.0.0.0
 no auto-summary

Router 2 configure:

interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0

interface FastEthernet0/1
 ip address 117.63.107.249 255.255.255.252

router rip
 version 2
 network 10.0.0.0
 network 117.0.0.0
 no auto-summary

Router 3 configure:

interface FastEthernet0/0
 ip address 117.63.107.250 255.255.255.252

interface FastEthernet0/1
 ip address 58.216.151.158 255.255.255.252

interface FastEthernet1/0
 ip address 117.63.107.146 255.255.255.252

interface FastEthernet2/0
 ip address 117.63.107.2 255.255.255.252

interface FastEthernet3/0
 ip address 37.3.7.1 255.255.255.248

router eigrp 2
 redistribute static
 redistribute rip metric 100000 1000 255 1 1500
 redistribute eigrp 200
 redistribute ospf 100 metric 100000 100 255 1 1500
 network 117.63.107.144 0.0.0.3
 no auto-summary
!
router eigrp 200
 redistribute static
 redistribute rip metric 100000 1000 255 1 1500
 redistribute eigrp 2
 redistribute ospf 100 metric 100000 100 255 1 1500
 network 117.63.107.0 0.0.0.3
 no auto-summary
!
router ospf 100
 router-id 3.3.3.3
 redistribute static metric 2 subnets
 redistribute rip metric 2 subnets
 redistribute eigrp 2 metric 2 subnets
 redistribute eigrp 200 metric 2 subnets
 network 37.3.7.0 0.0.0.7 area 0
!
router rip
 version 2
 redistribute static
 redistribute eigrp 2 metric 2
 redistribute eigrp 200 metric 2
 redistribute ospf 100 metric 2
 network 58.0.0.0
 network 117.0.0.0
 no auto-summary

ip route 219.230.155.0 255.255.255.0 FastEthernet0/1
ip route 219.230.155.0 255.255.255.0 58.216.151.157

Router 4 configure:

interface Loopback0
 ip address 219.230.155.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 58.216.151.157 255.255.255.252

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 58.216.151.158

Router 5 configure:

interface Loopback0
 ip address 75.126.203.247 255.255.255.128
!
interface Loopback1
 ip address 218.59.144.49 255.255.255.240
!
interface FastEthernet0/0
 ip address 117.63.107.145 255.255.255.252

router eigrp 2
 redistribute connected metric 100000 1000 255 1 1500
 network 117.63.107.144 0.0.0.3
 no auto-summary

Router 6 configure:

interface Loopback0
 ip address 221.4.246.81 255.255.255.240
!
interface Loopback1
 ip address 221.4.246.156 255.255.255.248
!
interface Loopback2
 ip address 125.39.72.81 255.255.255.128
!
interface FastEthernet0/0
 ip address 117.63.107.1 255.255.255.252

router eigrp 200
 redistribute connected metric 100000 1000 255 1 1500
 network 117.63.107.0 0.0.0.3
 no auto-summary
 

Router 7 configure:

interface FastEthernet0/0
 ip address 37.3.7.2 255.255.255.248

interface FastEthernet0/1
 ip address 78.7.8.1 255.255.255.252

interface FastEthernet1/0
 ip address 197.9.7.1 255.255.255.240

interface FastEthernet2/0
 ip address 132.7.10.1 255.255.255.252

router ospf 100
 router-id 7.7.7.7
 network 37.3.7.0 0.0.0.7 area 0
 network 78.7.8.0 0.0.0.3 area 1
 network 132.7.10.0 0.0.0.3 area 3
 network 197.9.7.0 0.0.0.15 area 2

Router 8 configure:

interface Loopback0
 ip address 8.8.8.8 255.255.255.0
!
interface Loopback1
 ip address 172.16.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 78.7.8.2 255.255.255.252

router ospf 100
 router-id 8.8.8.8
 redistribute connected metric 2 subnets
 network 78.7.8.0 0.0.0.3 area 1

Router 9 configure:

interface Loopback0
 ip address 210.22.23.74 255.255.255.192
!
interface Loopback1
 ip address 113.108.81.229 255.255.255.224
!
interface FastEthernet0/0
 ip address 197.9.7.2 255.255.255.240

router ospf 100
 router-id 9.9.9.9
 redistribute connected metric 2 subnets
 network 197.9.7.0 0.0.0.15 area 2

Router 10 configure:

interface Loopback0
 ip address 61.160.219.74 255.255.255.252
!
interface Loopback1
 ip address 170.117.70.10 255.255.255.240
!
interface FastEthernet0/0
 ip address 132.7.10.2 255.255.255.252

router ospf 100
 router-id 10.10.10.10
 redistribute connected metric 2 subnets
 network 132.7.10.0 0.0.0.3 area 3

  选择打赏方式
微信赞助

打赏

QQ钱包

打赏

支付宝赞助

打赏

  选择分享方式
  移步手机端
GNS3做RIP,EIGRP.OSPF路由重分布

1、打开你手机的二维码扫描APP
2、扫描左则的二维码
3、点击扫描获得的网址
4、可以在手机端阅读此文章
未定义标签

发表评论

选填

必填

必填

选填

请拖动滑块解锁
>>


  用户登录