Hi 你好,欢迎访问!登录
当前位置:首页 - Linux - 正文 君子好学,自强不息!

Kong API Gateway部署手册----版本升级

2017-06-13Linux撒加1823°c
A+ A-

Kong在0.10.x版本之前的话,做API网关,对于upstream_host并不能实现负载均衡,仅仅是靠DNS来实现对API服务的访问,从0.10.x开始,Kong支持了upstream的target添加,同时增加了upstream keepalive指令,对多个target可以通过ngx.balance来负载均衡,可以不依赖DNS了,这样的方式还是很不错的。

使用老版本Kong的用户一定想升级到最新版,但是升级是有风险的,比如会不会影响业务、数据库数据能否平滑升级等。如果仅仅是部署了一台Kong的话,很难做到平滑升级,这就需要在使用Kong的时候要注意整个架构的设计了。例如可以使用Keepalived+Kong的方式,分别升级两台Kong;也可以通过Haproxy来做。

Kong在升级的时候需要注意/opt/websuite/kong/luajit/share/lua/5.1/kong/templates/kong_defaults.lua,这个脚本中,必须要包含cassandra_contact_points这个配置项,如果用的是PGSQL这个一定得有,对于使用cassandra的用户忽略就可以了。

升级的话,需要按照参考https://www.nxops.cn/post/97.html 来部署新版本的Kong,安装完毕后,只要数据库配置无误,就可以使用kong migrations up来升级了,不报错就表示升级成功了

  选择打赏方式
微信赞助

打赏

QQ钱包

打赏

支付宝赞助

打赏

  选择分享方式
  移步手机端
Kong API Gateway部署手册----版本升级

1、打开你手机的二维码扫描APP
2、扫描左则的二维码
3、点击扫描获得的网址
4、可以在手机端阅读此文章
标签:

发表评论

选填

必填

必填

选填

请拖动滑块解锁
>>


  用户登录